Subscribe
Lync,Exchange,VoIP,telephony

Choose between insecure or “not working” : To apply or not MS Crypto API security update KB974571 on OCS …

October 19, 2009 By: Yann Espanet Category: KB articles, Office Communication Server

You have to choose between beeing secure or stop working with OCS according to Microsoft !:

Your evaluation period may be expired with this error in event viewver :

Event source: OCS Server
Event id: 12290
Event text: The evaluation period for Microsoft Office Communications Server 2007 R2 has expired. Please upgrade from the evaluation version to the full released version of the product.

So, you follow the “Upgrading Office Communications Server 2007 Evaluation to the Full Released Version” document :

http://www.microsoft.com/downloads/details.aspx?FamilyId=54A5521D-A928-46F2-8BF7-125DA636DD2E&displaylang=en

BUT here’s the result :

OCS Setup log :

Failure
[0xC3EC78D8] Failed to read the Office Communications Server version information. This can happen if the computer clock is not set to correct date and time.

 

After some research I’ve found that the workaround was to remove the MS Crypto API security update KB974571. So I removed the update, rebooted the machine, and OCS 2007 R2 was up and running again, without any issues.

What is the position of MS regarding this issue :

http://support.microsoft.com/kb/974571/en-us

Microsoft recommends to postpone installing KB974571 on any LCS 2005 / OCS 2007 /OCS 2007 R2 servers.

Microsoft is investigating this issue, and will determine the most appropriate way to address it. Customers who are not running OCS or LCS server are not affected by this known issue, and can safely ignore this issue.

Customers who have deployed the OCS or LCS product on a server should assess the risk that is involved to decide whether to install the security update on that server. These customers should revisit this Knowledge Base article often, because this article will be updated as soon as more information and a resolution are available.

Nice one from MS !

2 Comments to “Choose between insecure or “not working” : To apply or not MS Crypto API security update KB974571 on OCS …”


  1. Mark Ramsey says:

    I love you and want to have your childeren!! OH MY GOD I have fought with this for the past 2 days! Just uninstall the hotfix (KB974571) and all is right with the world for the time being!! Again your the best!!!!!!

    1
  2. You are great…

    2